FUEL Status - Elevated errors on SaaS Console analytics features – Incident details
Third Party: Scaleway → Elements - Products → Private Network experiencing degraded performance
Elevated errors on SaaS Console analytics features
Resolved
Major outage
Started 6 days agoJuly 21, 2026Lasted about 1 hourJuly 21, 202610:3411:25 PMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
We are investigating elevated errors affecting the Usage, Monitoring, and Log tabs in the SaaS Console. Some customers may experience errors or blank data when viewing these sections. The team has identified the issue and is working on restoration.